Knowledgebase: How To
How do I fix missing screenshots on my HTTPS secured web pages?
Posted by Brandon Elliott on 24 April 2017 04:17 PM

The errors in the logs will be: "Lock to account: IP not listed (site scraper or HTTPS mismatch?)"

If your web pages are secured with HTTPS and you use the "Embedded" method but you fail to use HTTPS to make requests from ShrinkTheWeb, then your visitors may not see the screenshots due to security mismatch. In this case, you need to ensure that all accesses to ShrinkTheWeb use HTTPS instead of just HTTP. In this case, ensuring that requests to ShrinkTheWeb also use HTTPS will avoid these errors, prevent you from having to upgrade to allow access, and save on service costs.

The reason is that all web servers are configured to NOT send proper domain-based header referrers from HTTPS secured domains that embed requests to HTTP links or assets. Therefore, our logs will likely block those referrers, as they will be end-user IPs, for free accounts or may detect this condition for paying accounts and enable IP Override (which is less secure). The "Best Practice" is to disable any IP Override under ShrinkTheWeb's security settings and ensure that all requests from your HTTPS site(s) use HTTPS to contact our service.

Note: If using the "Advanced" method, then it is unnecessary to use HTTPS, since the script works directly server to server, regardless of using HTTPS on your public pages or not.

(0 vote(s))
Helpful
Not helpful

Contact Us | PagePix Benefits | Learn More | STW Forums | Our Partners | Privacy Policy | Terms of Use

©2016 ShrinkTheWeb. All rights reserved. ShrinkTheWeb is a registered trademark of ShrinkTheWeb.